Redirect URLs behaving strangely on creation/deletion of properties

Follow

Comments

4 comments

  • Avatar
    Barrow Kwan

    are you using mod_proxy?  It seems to me a mod_proxy issue. 


    Can you check if you have enabled mod_proxy in your apache?


    if mod_proxy is enabled, check if you have this in your configuration


    ProxyPassReverse / http://localhost:9100/


    it will be helpful if you can post your apache configuration.

  • Avatar
    mattgow




    We have noticed that if we access Mingle directly we do not face this problem so there is definitely something wrong in this chain. We have tried the following options in Apache with the same results. Ideas?


    OPTION 1: Using mod_rewrite:


    RewriteEngine On
    RewriteRule ^/(.*)$ http://localhost:9100/$1 [P,QSA,NE,L]


    …and…


    RewriteEngine On
    RewriteRule ^/(.*)$ http://localhost:9100/$1 [P,QSA,L]


    OPTION 2: With mod_proxy:


    ProxyPreserveHost On
    ProxyRequests Off
    ProxyPass / http://localhost:9100/

  • Avatar
    Barrow Kwan

    I saw you have a ticket open with our support team.  If you can post your Apache configuration on that ticket, we can look into that for you.  ( or you can post it here in the community site if you are comfortable ).  Although we might not be able to find a clue from your Apache configuration, it will be helpful if we have that information.


    I have mentioned about ProxyPassReverse in my previous post but I didn't seem to see you have that option in either of your options above.  Did you have that in your configuration?


    with mod_proxy, the simple version will be


    ProxyPass / http://localhost:9100/


    ProxyPassReverse / http://localhost:9100/

  • Avatar
    Brian Smith

    I am having the same issue with Mingle 3.3.1.  Was modifying apache configuration the ultimate fix?  Please let me know so that I have a place to start with this.


     


    Thanks

Please sign in to leave a comment.