Dependency error during installation

Follow

Comments

6 comments

  • Avatar
    Phil Richards

    The --nodeps option seems to bypass all the configuration stuff that needs to be done after the software is copied down.  I have several 1.6 jre and jdk installations, all configured throught alternatives, but it still cannot find java.  I have JAVA_HOME set for the default user, and for root.  Why is the rpm package unable to find java?

  • Avatar
    Phil Richards

    I figured it out.  You didn't mention that Java has to be installed via RPM so that the RPM dependency will pick it up. 

  • Avatar
    Amulya

    any solution for this .. 

  • Avatar
    Jyoti Singh

    Go v12.x and earlier versions of Go required Java to be installed as a rpm package, but its not true any more. Go rpm installers version 13.x and above do not have a install time dependency on Java anymore. However, you should know that Go requires java to be installed on the machine. If java is not installed or not available in path, installation of Go server and agent would go through but the application startup will fail.

    Also, the Go community pages have moved to mailing lists. You can find the links on go.cd . There are more people there to help.

     

  • Avatar
    Xinyu Wang

    Hi guys,

     

    I installed Go Server in 

     

    CentOS release 6.6 (Final), 

     

    Java version "1.7.0_71"

    Java(TM) SE Runtime Environment (build 1.7.0_71-b14)

    Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

     

    ruby 1.9.3p448 (2013-06-27 revision 41675) [x86_64-linux]

     

    But show these errors, I’m not sure it’s a bug or environment issue.

     

    Could you take a look?

     

     

    Internal Server Error (500)

    Request Method:

    GET

    Request URL:

    http://112.124.43.62:8153/go/rails/rails/home

    can't activate rack (~> 1.0.0, runtime) for [], already activated rack-1.4.5 for [] from file:/var/lib/go-server/work/Jetty_0_0_0_0_8153_cruise.war__go__.mt8b37/webapp/WEB-INF/lib/jruby-rack-0.9.6.jar!/jruby/rack/rails.rb:50:in `require_frameworks_with_servlet_env' from /var/lib/go-server/work/Jetty_0_0_0_0_8153_cruise.war__go__.mt8b37/webapp/WEB-INF/rails/vendor/rails/railties/lib/initializer.rb:134:in `process' from /var/lib/go-server/work/Jetty_0_0_0_0_8153_cruise.war__go__.mt8b37/webapp/WEB-INF/rails/vendor/rails/railties/lib/initializer.rb:113:in `run' from /var/lib/go-server/work/Jetty_0_0_0_0_8153_cruise.war__go__.mt8b37/webapp/WEB-INF/rails/config/environment.rb:17 from /var/lib/go-server/work/Jetty_0_0_0_0_8153_cruise.war__go__.mt8b37/webapp/WEB-INF/rails/config/environment.rb:33:in `load' from file:/var/lib/go-server/work/Jetty_0_0_0_0_8153_cruise.war__go__.mt8b37/webapp/WEB-INF/lib/jruby-rack-0.9.6.jar!/jruby/rack/rails.rb:33:in `load_environment' from file:/var/lib/go-server/work/Jetty_0_0_0_0_8153_cruise.war__go__.mt8b37/webapp/WEB-INF/lib/jruby-rack-0.9.6.jar!/jruby/rack/rails.rb:156:in `new' from

     

     

  • Avatar
    Mansi Shah

    Hi Xinyu Wang,

    This forum is available only for reference. Could you please redirect your queries to go-cd

Article is closed for comments.